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E3. series Releasenotes 
Date: 29.05.2015 

  

This manual describes the following functions of version: 

2015 Build 16.00 

!! Please Note when Switching to New Version !! 
Projects and databases are converted when opening them with this new E3.series Release. 
Please consider that these projects cannot be edited with an older version afterwards. That's 
why we recommend to backup projects before. 
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Update Information of Version 2015 

o Windows Support 
o Installation 
o Databases 
o Projects 
o Multi-User Installation 
o ORACLE 
o Microsoft SQL Server 

Windows Support 

The following Windows systems are supported with E3.series 2015: 

• Windows Vista 
• Windows 7 
• Windows 8 
• Windows Server 2003/2008 

For more information please refer to the installation description. 

Installation 

Before installing, we recommend you make a backup of your current installation (at least the 
data and databases). 

The installation of E3.series 2015 is started using 

SETUP.EXE 

which can be found on the DVD's main directory. 

The Version can be installed in addition to an existing E3.series Version. 

The Default Directory is: \Program Files\Zuken\E3.series_<version> 

Therefore, this version can also be used alongside existing versions of E3.series. However, 
note that you cannot use your existing database(s), or the existing projects, in both versions, 
as they are updated when opened in E3.series 2015, so copies should be used for E3.series 
2015. 

  

Databases 

With this new version, a new default database is installed. Existing databases are not 
overwritten. 

The new database contains new components and symbols. 

Projects 

Existing projects are automatically converted upon opening with the new version. So long as 
the file has not been saved in the new version, it can still be opened with an older version. 
After saving a project with E3.seriesVersion 2015, a project can no longer be opened with an 
earlier version. 
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Multi-User Installation 

Existing multi-user projects from Version 2014A can directly be opened with Version 2015. 
They are automatically converted upon opening. However, this cannot be undone, and the 
projects can no longer be opened with Version 2014A. 

That’s why we recommend installing Version 2015 multi-user projects in parallel to the existing 
version, so that it’s also possible to still access these project with E3.series Version 2014A. 

To transfer the projects to Version 2015, these projects must be saved in Version 2014A as 
Single-User projects. They can then be stored in the multi-user environment of Version 2015. 

In order to run the Multi-User databases in parallel, a new SQL Server process must be 
installed for Microsoft SQL Server and a new database user account for ORACLE. 

The E3 Server process must then access the new database or the new database user account. 

ORACLE 

When setting up the E3-MU-Server, a new name must be specified for the Multi-User 
Administrator. 

Thus a new database user account is created and both E3.series versions can work 
simultaneously in the multi-user environment. 

Microsoft SQL Server 

First, a new instance of the SQL Server processes must be installed. 

Enter a new instance name, which must be used with the set-up installation of the E3-MU-
Server. 

The rest of the installation continues as described in the separate MuSetup installation 
description. 
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New Features 2015 Build 16.00 

The following functionality is new in Version 2015 Build 16.00: 

  

• Cables / Conductors / Wires 

o Cables / Conductors / Wires - Miscellaneous Enhancements 
o Cabling Table  

  

• COM 

o New Trigger AfterCreateDevice after Creating a Device 
o New Trigger AfterDeleteDevice after Deleting a Device 
o New Triggers for Signals and Signal Classes 
o The Trigger BeforeCheckOutSheet Now Receives a Parameter 
o COM Command Create2DView Receives New Value for Parameter 'modi' in 

DeviceInterface 
o New COM Commands in the NetInterface for Changing Signal Names 
o New Trigger BeforeModifyAttribute 
o Enhancement to ComponentInterface for Returning the Defined View 

Symbols of a Component with Their User-Specific View Numbers 
o New Trigger AfterConnectMUProject 
o Enhancement to JobInterface for Displaying a List of Drawing Elements in 

a Predefined Color with PDF Export 
o Enhancement to SymbolInterface for returning Duplicate Attribute Text 

Template Symbols whose Polygon Points refer to Origin's Coordinates 
o Enhancement within the PinInterface to set the maximum number of 

connections on a pin 

  

• Connections/Buses, Signals/Logic Lines, Supply 

• Conductor Logic Lines 
o Conductor Logic Lines Can Now Be Displayed for Selective Signals 
o Logic Lines of Not Connected Conductors Can Now Be Displayed as 

Arcs 
• New Functionality in E3 'Reorder Conductors 
• New Functionality in E3 'Signal Format'  
• Misc 

• Alternative Template Symbol Can Now Be Defined in the Settings 
• New Check Box in Settings for Deleting Signals of Not Connected 

View Symbols 
• Define whether the Signal on a Pin Shall Be Removed when 

Unconnecting Conductors/Wires on a Pin 

  

• Connectors 

o Connector Pins Can Now Be Placed as Single Pins when Changing a 
Component or Updating a Project 
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o User-Defined View Numbers for Connector Views 
o New Options for Assigning Numbers to Connectors and Mating Connectors 

in the Settings 

  

• Fluid 

o 'Electric Settings' and 'Fluid Settings' Can Now Be Called Up in the 
Settings 

o Special Options with Separate Values for the Respective Discipline 
o Enhancement to JobInterface: COM Command 'SetDisplayConnectPoints' 

with Own Settings for Fluid 

  

• Formboard 

o New Options for Inserting Nodes using the Formboard Dialog 'Add Node' 
o Pins without Placed Conductors/Wires Can Now Be Displayed in the 

Formboard Connector Table 
o Two Additional Possibilities Now for Automatically Routing Wires Assigned 

Options in Formboard 

  

• Graphics / Dimensions 

o Three New Dimension Line Types Available 
o New Functionality 'Running Dimension' 
o Enhancements to DimensionInterface for Generating and Adapting 

Running Dimensions 
o Dimension Text of Running Dimensions Can Be Rotated 
o Enhancements to DimensionInterface for Displaying Dimension Text of 

Running Dimensions as Rotated 

  

• Import/Export (subcircuits) 

o Connection Direction of Conductors/Wires Can Be Ignored when 
Importing Subcircuits  

o DWG/DXF Import/Export Now Compatible with AutoCAD Version 2013 

  

• Panel 

o New Section '2D View Options' in 'Insert New Sheet' Dialog in E3.panel 
o Already Placed 2D Views Can Now Be Deleted 
o Symbol Properties Can Now Be Opened when Placing Models on Panel 

Sheets 
o New '3D View' Toolbar in Panel 
o Models Can Now Be Set as Transparent or Invisible in the 3D View   
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• References 

o New Drop-Down Menu 'Format:' in the Settings for Defining How the Text 
Type 'Sheet Reference' Can Be Displayed 

  

• Text 

o Two New Text Types in E3 for Referencing between Symbols in Circuit 
Diagrams and Components on Panel Sheets 

o Display of Multiline Texts Can Now Be Defined in the Symbol Properties for 
Symbols of the Type 'Attribute Text Template' 

o Lines Can Now Be Added to Text Boxes 
o Parameter Values Can Now Be Defined using Placeholders for Translated 

Text Nodes from the Translation Table 
o Ten New Sheet Text Types in the Database 

  

• User Interface 

o 'Full Screen Mode' for Workspace in E3.series 

  

• Variants / Options 

o Variants/Options Tree Can Now Be Structured using Folders 
o All Elements in Variants/Options Tree Can Now Be Sorted in Ascending or 

Descending Order 

  

• Views 

o Dialogs 'New View' and 'Place on Formboard' Have Been Enhanced 
o Control whether Active Connector Pin Terminal Symbol Shall Be Displayed 

for Views in the Device Properties 
o Keep pinview symbols at project update 
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Cables / Conductors / Wires - Overview 

The cable list is now available in E3.series. The following chapters describe the new 
functionality and other enhancements: 

• Cabling Table 

  

• Cables / Conductors / Wires - Miscellaneous Enhancements 

o Conductors/Wires Can Now Be Easily Moved from Pin to Pin 
o Wire Groups Can Now Be Displayed with Alternative Names in the Drop-

Down List 
o Additional Connector Pin Terminal Information Can Now Be Defined on 

Symbols 
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Cabling Table 

In project mode in E3.series there is now a Cabling Table, in which all connected graphical 
connections are listed with their devices in the project. The individual conductors of a cable are 
listed. Wires, hoses, tubes and jumpers are not displayed in the Cabling Table. With the help of 
this Cabling Table cables can be placed more effectively on connections. 

Detailed information can be found in the following chapters: 

• Displaying the Cabling Table 
• Adding/Deleting Columns 
• Configuring the Cabling Table 
• Global Search in the Cabling Table   
• 'Jump to' Functionality in the Cabling Table 
• Display Ignored Connection Lines in the Cabling Table   
• Context Menu Commands in the Cabling Table 
• Setting/Resetting the Preselection 
• New Check Method 'Checking graphical connections - (0050) None unique' 
• Enhancement to JobInterface for Checking Ambiguous Connections in the 

Project 
• Enhancement to NetSegmentInterface for Marking Connections Which Shall Not 

Be Displayed in the Cabling List 

  

Displaying the Cabling Table 

The Cabling Table can be called up as follows: 

• click on the command View -> Cabling Table in the main menu, 
or 

• right-click on a connection line and select the command Cabling Table... in the 
displayed context menu. 
Note: This context menu command is not displayed for a connection line in E3.panel. 

Each row in the (Excel-like) table describes a pin to pin graphical connection and is divided into 
two levels: 

• In the first level (Device Level) the connections are displayed from device to device 
(single pin/single row).  
Moreover, the status of the cabling state on the graphical connection is displayed; the 
following is valid: 

• Red: No cabling  
• Yellow: Partial cabling exists 
• Green: Complete cabling 

• In the second level (Pin Level) the connections are displayed on the pin level (multi 
pin/multi row). Only pins are displayed which have no wires, hoses and tubes applied  
Note: This level can be displayed by clicking on the  button and hidden with the  
button. 
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By default the columns in the first level display the following information: 
Note: These columns cannot be deleted. 

• Assignment - From 
• Location - From  
• Device designation - From  
• Assignment - To 
• Location - To 
• Device designation - To 
• Cable Name 
• Cabling State 

  

By default the columns in the second level display the following information: 
Note: These columns cannot be deleted. 

• From Pin 
• From Pin Position 
• Conductor Name 
• Conductor Position 
• Bundle Name 
• To Pin 
• To Pin Position 

  

Adding/Deleting Columns 

All attributes can be displayed in the Cabling Table according to their database definitions. 
These attributes can be displayed in additional columns. 

To do so, select the table column header and then the context menu command Add Column.  

The dialog box Add Columns appears: 
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If an attribute appears more than once on an owner, the attribute can be selected repeatedly 
as a new column in the drop-down list. The headers of columns with the same attribute names 
appear with the number of the copy in brackets. 

The command Remove Column deletes the column.  

Configuring the Table  

The columns can be configured as follows: 

• Columns of tables can be configured and arranged in any order. The columns of a table 
can be sorted based on the contents of a column using the command Sort Ascending or 
Sort Descending. By double-clicking on a column header the column can be sorted in 
ascending or descending order as well.. 

• The individual columns can be moved anywhere using Drag&Drop. 

• By specifying a filter the output can be more selective (limited). Right-click on one of the 
two uppermost cells in first column of the window and select the command Show Filter. 
Note: When searching, it's recommended to type an asterisk in front of the expression 
to be searched: *Search Term 
When resetting the filter, just type an asterisk in the cell: * 

• The configuration of the tables, i.e. the displayed columns, width and order of the 
columns as well as the visibility of filtered rows, is saved in the project. This 
configuration is user-specific in a multi-user project.  

  

Global Search in the Cabling Table 

It's possible to perform a global search in the Cabling Table. Not only does it search a fixed 
column but all locations in the Cabling Table. 

To start the search: 

• right-click on one of the two uppermost cells in the first column of the window and select 
the command Search 
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or 
click on the F7 key 

• The Search dialog window opens: 

 

 

Search 
 

OK / 
Cancel 

The term to be searched in the table can be entered in the text field. 

Note: A question mark '?' (for an individual character) and an asterisk '*' (for 
several characters) can be used as wildcards for the search. 

OK executes the search. 

Cancel aborts the search.  

. 
 

All results are displayed in the project, where this search entry appears. Furthermore, the 
search term is enclosed in brackets after the cabling table header: 

 

  

To reset the search: 

• right-click on one of the two uppermost cells in the first column and select the command 
Reset Search 
or 
click on the key combination SHIFT + F7 
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'Jump to' Functionality in the Cabling Table  

'Jump to' functionality is available in the Cabling Table. The 'Jump to' functionality offers the 
possibility to easily and quickly jump to objects within the project. Different 'Jump to' 
commands are available for selection depending on the level in the Cabling Table. 

On the first level (Device/Cable Level) are the following Jump commands: 

• Jump to Schematic 
• Jump to Panel 
• Jump to Terminal Plan 
• Jump to Device Tree 
• Jump to Panel Tree (Placed) 

On the second level (Pin/Conductor/Net Level) are the following Jump commands: 

• Jump to Schematic 
• Jump to Panel 
• Jump to Device Tree 
• Jump to Signal Tree 

  

To execute the 'Jump to' command:  

• right-click on the desired cell in the Cabling Table and select the command Jump to in 
the displayed context menu, 

• click on the corresponding Jump to command in the opened context menu. 

  

The sheet with the marked symbol is opened automatically. If it is already opened, it is moved 
to the foreground. The drawing area is correspondingly adapted in order to have a clear 
overview of the selected object. Furthermore, the object is highlighted with a rectangle.  

To reset the highlighting, 

• click on the command Edit -> Reset Highlight in the main menu, 
or 

•  press the key combination SHIFT+F3 . 

Display Ignored Connection Lines in the Cabling Table  

It's possible to ignore connection lines in the Cabling Table. Moreover, the connection lines to 
be ignored can be highlighted using an alternative color. This is valid for all connection lines, 
on which no conductor is placed.  

To do so, there is the new section Ignore for Cabling Table in the Settings under 
Connection -> Connection Lines. 
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Connection - Connect Lines 
 

Ignore for Cabling Table 

Display ignored 
connect line in 
alternative 
color 

When checked, the desired connection lines can be ignored in the Cabling 
Table. These ignored connection lines are displayed in the schematic with 
the alternative color. 

Note: The connection line is also displayed in the alternative color if only 
wires, tubes and hoses are located on the connection line. 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used:  
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DISPLAY_IGNORED_CONNECT_LINE 

This check box is user-specific in a multi-user project. 

Ignore new 
connections in 
Cabling Table 

When checked, all newly added connections in the Cabling Table can be 
ignored. 

Alternatively, this functionality can also be controlled using the new icon 
Ignore in cabling table (in the Connection toolbar).  

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used:  

IGNORE_NEW_CONNECT_LINE_IN_CABLING_TABLE 

This check box is user-specific in a multi-user project. 

  

Color 
Defines the color for the ignored connection lines.  

If 'Automatic' is selected, the color defined in the Color Definitions dialog 
box (called up in the Database Editor under Format-> Color 
Definitions...) is used. 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used:  

COLOUR_IGNORED_CONNECT_LINE 

This check box is project-specific in a multi-user project. 

  

. 
 

  

Example: 

To ignore a connection line or the thereupon connected device that shall not appear in the 
Cabling Table: 

• right-click on the desired connection line or the device, which shall be ignored in the 
Cabling Table, 

• then select the command Ignore for Cabling Table in the opened context menu 
• the connection line or the thereupon connected device are suppressed in the Cabling 

Table. 

Note: Connections with conductors are permanently displayed in the Cabling Table. As soon as 
all the conductors are disconnected on the connection, the connection line or the thereupon 
connected device is suppressed in the Cabling Table. 
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To no longer ignore the connection line or the thereupon connected device: 

• right-click on the ignored connection line or the ignored device,  
• then select the command Allow for Cabling Table in the opened context menu, 
• the connection line or the thereupon connected device is displayed again in the Cabling 

Table. 

  

Context Menu Commands in the Cabling Table 

Depending on where one clicks in the Cabling Table, on which level (see Displaying the 
Cabling Table) and column with the right mouse button, different context menu commands 
are available: 

  

Insert Template Symbol 

Note: This context menu command can only be called up in the first column of the Pin Level 
or in the columns Conductor Name, Conductor Position or Bundle Name. 

After executing the context menu command Insert Template Symbol, the system jumps to 
the selected connection line, on which the template symbol shall be inserted. 

  

Unconnect Conductors 

• If the context menu command is executed in the Device Level, all conductors are 
unconnected on the device. 

• If the context menu command is executed in the first column of the Pin Level or in the 
columns Conductor Name, Conductor Position or Bundle Name, the conductor is 
unconnected on the pin. 

  

Assign Cable... 

• If the context menu command is executed in the  Device Level, the cable's conductors 
are assigned to the complete device. 

• If the context menu command is executed in the Pin Level, one cable conductor is 
assigned to the pin. 

Executing this context menu command opens the Assign Cable dialog:  
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Assign Cable 
 

Assign existing cable: 
Select a cable: 

All cables are displayed in the drop-down list, which fulfill the following 
prerequisites in the project: 

• The cable has at least as many conductors as the number of pins 
available on the connection line. 

• The conductors of the cable fulfill the cross-section specifications of 
the pins. 

Clicking on this button  opens the Select Existing Cable dialog: 
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All useable cables within a project are displayed in the form of a tree 
structure here. 

By checking the check box List all cables all cables in the project are 
displayed (as well as already placed). 

Assign new cable:  
  

Select a cable: 
All cables within a project and from the database are displayed in the drop-
down list, which fulfill the following prerequisites: 

• The cable has at least as many conductors as the number of pins 
available on the connection line. 

• The conductors of the cable fulfill the cross-section specifications of 
the pins. 

Clicking on the button  opens the Select Cable Type dialog: 
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The following cables are displayed here in the form of a tree structure: 

• all useable cable types (number of conductors / cross-sections that 
meet the pin requirements) from the database  

• all useable cables (number of conductors / cross-sections that meet 
the pin requirements) within a project 

By checking the check box List all cable types all cable types from the 
database and the project are displayed. 

. 
 

  

Swap Conductors 

Note: This context menu command can only be executed in the Pin Level 

o if both conductors to be swapped are from the same cable 
o if only one conductor on a free pin shall be swapped  
o To do so, press and hold the SHIFT or Ctrl key and then left-click on the desired 

conductor in the first column. Afterward, right-click anywhere and select the context 
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menu command Swap Conductors: 

 

After executing the context menu command Swap Conductors, both conductors are 
exchanged with one another.  

  

Device Properties... 

Note: This context menu command can only be executed in the Device Level.  

After executing the context menu command Device Properties..., the Device Properties - 
Device dialog opens.  

  

Pin Properties... 

Note: This context menu command can only be called up in the first column of the Pin Level 
or in the columns From Pin, From Pin Position, To Pin or To Pin Position. 

After executing the context menu command Pin Properties..., the Device Properties - Pins 
dialog opens.  

  

Conductor Properties... 

Note: This context menu command can only be called up in the first column of the Pin Level 
or in the columns Conductor Name, Conductor Position or Bundle Name. Additionally, one 
conductor must be placed. 

After executing the context menu command Conductor Properties..., the Device Properties 
- Wire Information dialog opens.  

  

Setting/Resetting the Preselection 

Defining the Preselection for the Cabling Table 

By filtering using preselected connections and devices the Cabling Table can be defined 
accordingly. The filtering action gives the user a better overview of the Cabling Table because 
only the desired connections and devices are displayed. 

  

To define the preselection for the desired connected graphical connections, which shall be 
displayed in the Cabling Table: 

• pressing the SHIFT key and select the desired connection line or device in the schematic, 
• right-click on one element of the selection, 
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• select the command Cabling Table... in the displayed context menu, 
• this opens the Cabling Table with the preselected selection: 

 

  

Resetting the Preselection for the Cabling Table 

The filtering in the Cabling Table using preselected connection lines or devices can be reset. 

To reset the preselected Cabling Table to its original state: 

• right-click anywhere in the first column of the Cabling Table, 

 
• then select the command Reset Preselection in the displayed context menu. 

 After resetting, the Cabling Table appears with all connected graphical connections in the 
project. 

  

Reference(s): Designer-25598 

New Check Method 'Checking graphical connections - (0050) None unique' 

Additionally, there is the new check method Checking graphical connections - (0050) 
None unique in the standard check programs of E3.series (called up using Tools -> Verify). 
When executing the check method, all non-unique connections are listed in the 'Results 
Window'. 

Example: 
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Unique graphical 
connection:  

The connection 
pathway is unique 
because there is only 
one placement 
possibility. 

 

No unique graphical 
connection: 

The connection path 
is not unique because 
there are several 
possibilities. 

 

Unique graphical 
connection:  

The connection path 
is unique based on 
the "forced wiring". 

 

No unique graphical 
connection: 

The connection path 
is not unique because 
conductors/wires are 
not placed on all 
graphical connection 
lines.  
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Unique graphical 
connection:  

The connection path 
is unique because 
conductors/wires are 
placed on all graphical 
connections. 

Note: Please make sure the XML check file contains the new check method. The XML check file 
is called up in the Registry 
(HKEY_CURRENT_USER\SOFTWARE\Wow6432Node\Zuken\E3.series\<version>) with the 
character string VerifyXMLPath for E3.series or VerifyXMLPath_Logic for E3.logic. 

Enhancement to JobInterface for Checking Ambiguous Connections in the Project 

There are the following new COM commands in the JobInterface: 

• cnt = job.GetAllConnectionIds ( ids [,flags] ) 
• cnt = job.GetSelectedConnectionIds ( ids [,flags] ) 

o o flags has been enhanced: 
o flags = 0x4 when the flag is set, formboard connections are ignored. 

  

Reference(s): Designer-25609 

Enhancement to NetSegmentInterface for Marking Connections that Shall Not Be 
Displayed in the Cabling List 

There is the following new COM command in the NetSegmentInterface: 

• ret = ns.SetIgnoreForCablingTable ( set ) 

o set 1 Connections are ignored in the cabling list. 
o set 0 Property reset 
o ret The return value can have the following values: 

 0: The property was previously not set on the net segment. 
 1: The property was previously set on the net segment. 
 -1: No project 
 -2: Item is not a net segment. 
 -3: The net segment is part of a formboard or topology net. 

Reference(s): Designer-25603 
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Cables / Conductors / Wires - Miscellaneous Enhancements  

• Conductors/Wires Can Now Be Easily Moved from Pin to Pin 
• Wire Groups Can Now Be Displayed with Alternative Names in the Drop-Down 

List 
• Additional Connector Pin Terminal Information Can Now Be Defined on Symbols 

Conductors/Wires Can Now Be Easily Moved from Pin to Pin 

Now it's possible to move conductors/wires easily from pin to pin in E3.series. The following 
options are available for determining which shall be used when moving: 

• Use only selected pins 
• Use signal-equivalent pins 
• Use name-equivalent pins 
• Use pins of original symbol 

The desired option must be defined before the move takes place. To do so, use the new drop-
down list in the section Move Conductor Ends under Connection - Conductors/Wires. 
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Conductors/Wires 
 

Move Conductor 
Ends 

Determining which pins shall be used when moving can be defined here:  

  

• Use only selected pins 

o The command tries to move conductors/wires only on directly 
selected pins. 

• Use signal-equivalent pins 

o The command tries to move conductors/wires on directly 
selected pins as well as on all corresponding signal equivalent 
pins. 

• Use name-equivalent pins 

o The command tries to move conductors/wires directly on 
selected pins as well as on all corresponding name equivalent 
pins. 

• Use pins of original symbol 

o The command tries to move conductors/wires directly on 
selected pins as well as on all pins which are available on the 
symbol of the original view.  
Note: If the original symbols are equal, the assignment of 
symbols will also be swapped. 

  

For the COM methods prj.GetSettingValueand prj.SetSettingValue the 
following setting_name can be used: MOVE_CONDUCTOR_ENDS. 

This check box is user-specific in a multi-user project. 

. 
 

Note: 

• Starting and target pins can also be selected in reverse order. 
• If conductors/wires are placed on both the starting and the target pins, they are 

swapped.  
• If conductor/wire ends cannot be moved (e.g. due to invalid cross-sections), they remain 

on the original pin. 
• If there are overlaps at the mass of the selected starting and target pins, an attempt will 

be made to move the conductor/wire ends further. 
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To move conductors/wires from one pin to another:  

Use the new Move conductors icon in the toolbar - category Connect to start the command. 

Step 1: 

• Left-click on the Move conductors icon  to activate the command. 
Note: double-clicking on the icon allows the user to repeat the command as often as he 
likes. 

• All pins and open line ends on the current sheet are displayed by a square: 

 

  

Step 2:  

Select the starting pin, on which the conductor/wire ends are connected and that shall be 
moved to another target pin.  

• Left-click on the desired pin or if several pins need to be selected,  
• drag a rectangle around the desired pins while pressing the left mouse button.  

Note:  

• Depending on the setting in the Move conductor ends drop-down list (see above), the 
corresponding pins are added to the selection automatically. 

• The selected starting pins are marked with a triangle (pointing upwards). 
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Step 3: 

• Left-click on the target pin where the conductor/wire ends should be moved or if several 
pins need to be selected, 

• drag a rectangle around the desired pins with pressing the left mouse button. 

Note: 

• Depending on the setting in the Move conductor ends drop-down list (see above), the 
corresponding pins are added to the selection automatically. 

• The selected target pins are marked with a triangle (pointing downwards).  

 

  

Step 4: 

After the target pin has been selected, the new assignment of the conductor/wire ends occurs. 

 

Note: 

• If several conductor/wire ends exist, the assignment is based on the position of the pins 
on the sheet. 
The sorting takes place first in ascending Y order and then in ascending X order. 

• All new connected conductors/wires are displayed in Results Window after moving. 

  

Reference(s): Designer-25501 
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Wire Groups Can Now Be Displayed with Alternative Names in the Drop-Down List  

In E3.series the value of an attribute can be defined in the tree structure, which is then 
displayed in the drop-down list instead of the component name. This was not true for wire 
groups.  

From now on the functionality is also available for wire groups.  

• To do so, right-click on the name of the component database in the component tree 
structure, 

• select the context menu command Tree Structure, 
• select a structure to use under Use Structure in the Database Tree Structure dialog,  
• check the check box Redefine Structure and then select the desired attribute in the 

drop-down list for components (in the following example 'Supplier'): 

 
• update the component structure view by clicking the F5 key 

  

The wire groups corresponding with the attribute value (in this case according to 'Supplier') 
are now listed in the wire group drop-down list:  

In the Wire Setting toolbar: 
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In the Settings Connection - Conductors /Wires: 

 

  

In the Wires tab of the Connection Properties: 
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In the Wire Information tab of the Connection Properties: 
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Reference(s): Designer-18237 

Additional Connector Pin Terminal Information Can Now Be Defined on Symbols 

Additional information can now be displayed on the active connector pin terminal of a pin using 
a text type.  

For defining this additional connector pin terminal information there is the new option Use 
from active pin terminal in the Edit Text Types dialog in Database Editor Mode: 
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Note: 

An attribute must also be selected under Assigned attribute, which references the 
information for the active connector pin terminal later. This attribute must have the owner 
'Component'. 

If the check box Use from active pin terminal is checked, the text type is evaluated for...  

• connector symbols/block connector symbols (must be connected with the symbol pin) 
• normal symbols (must be connected with the symbol pin) 
• formboard tables 
• attribute text template symbols. 

If the pin... 

• on the node 
• on the attribute text template symbol 
• in the row of the Formboard Table 

doesn't have a unique connector pin terminal, the text is not filled in. 

  

Reference(s): Designer-22515 
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COM-Interface 

• New Trigger AfterCreateDevice after Creating a Device 
• New Trigger AfterDeleteDevice after Deleting a Device 
• New Triggers for Signals and Signal Classes 
• Trigger BeforeCheckOutSheet Now Receives a Parameter 
• COM Command Create2DView Receives New Value for Parameter 'modi' in 

DeviceInterface 
• New COM Commands in NetInterface for Changing Signal Names 
• New Trigger BeforeModifyAttribute 
• Enhancement to ComponentInterface for Returning the Defined View Symbols 

of a Component with Their User-Specific View Numbers 
• New Trigger AfterConnectMUProject 
• Enhancement to JobInterface for Displaying a List of Drawing Elements in a 

Predefined Color with PDF Export 
• Enhancement to SymbolInterface for returning Duplicate Attribute Text 

Template Symbols whose Polygon Points refer to Origin's Coordinates 
• Enhancement within the PinInterface to set the maximum number of 

connections on a pin 

New Trigger AfterCreateDevice after Creating a Device  

The trigger is activated after generating a device. 

Can be accessed using the following parameter: 

• 1: ID of the newly generated device 

  

Reference(s): Designer-20169 

New Trigger AfterDeleteDevice after Deleting a Device  

The trigger is activated after deleting a device. 

An array with the GID and object ID is returned as a parameter: 

• Array(0): GID of the deleted device 
• Array(1): Object ID of the deleted device 

Note: 

Afterward, the returned IDs are no longer valid and cannot be reused within the COM 
interface.  
These IDs can be used to update external references, e.g. in Excel files or databases. 

Example: 

Start 
   
 Sub Start() 
     Set e3 = CreateObject("CT.Application") 
   
     args = e3.GetScriptArguments 
     For i = 0 to UBound(args) 
           
         MyArray = Split(args(i), ",", -1, 1) 
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         e3.PutInfo 0, "Item has been deleted: " 
         e3.PutInfo 0, "     GID: " & MyArray(0) 
         e3.PutInfo 0, "     ObjectID: " & MyArray(1) 
   
     Next 
     Set e3 = Nothing 
 End Sub 

Reference(s): Designer-25495 

New Triggers for Signals and Signal Classes 

There are the following new triggers: 

AfterCreateSignal 

The trigger is executed after generating a signal or signal class. 

AfterModifySignalName 

The trigger is executed after changing the name of a signal or signal class. 

AfterModifyReferenceItemsOfSignal 

The trigger is executed after adding or deleting objects (e.g. pins, nodes, net nodes, 
core/wires) of a signal. 

All triggers can access the following arguments:  

• 1: all signal IDs and signal class IDs 

  

Example: 

Start 
    
 Sub Start() 
     Set e3 = CreateObject("CT.Application") 
     Set prj = e3.CreateJobObject() 
     Set sig = prj.CreateSignalObject() 
     Set sigClass = prj.CreateSignalClassObject() 
    
     args = e3.GetScriptArguments 
     For i = 0 to UBound(args) 
         signalItem = sig.SetId( args(i) ) 
           
         If signalItem = 0 Then 
             sigClass.SetId args(i) 
             e3.PutInfo 1, "Signal class: " & sigClass.GetName() & " changed" 
         Else 
             e3.PutInfo 1, "Signal: " & sig.GetName() & " changed" 
         End If 
     Next 
     Set e3 = Nothing 
 End Sub 
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Reference(s): Designer-13562 

Trigger BeforeCheckOutSheet Now Receives a Parameter 

The trigger BeforeCheckOutSheet receives an argument as a parameter specifying which 
type of checkout shall be performed: 

• 1 for Read/Write 
• 2 for ReadOnly 

  

Reference(s): Designer-13930 

COM Command Create2DView Receives New Value for Parameter 'modi' in 
DeviceInterface 

In the DeviceInterface the following COM commands have been changed: 

• ret = dev.Create2DView ( modi, name, symbol, position, before )   

o modi 0x000 Previously, the value was always 0. The display in the "base sheet" 
disappears as soon as the component is displayed on a 2D view sheet. 

o modi 0x001 When generating a 2D view, the component is still visible on the 
"base sheet", i.e. the cell appears twice. 

  

• ret = dev.GetPanelLevel 

o The return value has been changed: 
o ret Returns the level same level for all cells, otherwise -1. 

Reference(s): Designer-19431 

New COM Commands in NetInterface for Changing Signal Names 

In the NetInterface there are the following new COM commands: 

• ret = net.GetSignalName  

o ret Returns the signal name of the current net. 

• ret = net.GetTranslatedSignalName  

o ret Returns the translated text for the signal name. If there is no translation, the 
internal signal name is returned. 

• ret = net.SetSignalName ( name )  

o name New signal name of the net 
o ret The return value is 1 if successful, otherwise 0. 

• ret = net.SetSignalNameOnLocalNet ( name )  
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o name New signal name of the net. If additional nets are connected by references, 
the signal is not changed there. 

o ret The return value is 1 if successful, otherwise 0. 

In the ConnectionInterface the following COM command has been changed: 

• ret = con.SetSignalNameOnLocalNet ( name )  

o This command is replaced by the COM command with the same name in the 
NetInterface. 

o It now behaves like con.SetSignalname(name). The specified signal is transferred 
over the entire net. The signal is also inherited over references. 

  

Reference(s): Designer-25939 

New Trigger BeforeModifyAttribute 

The trigger is executed if one of the attributes to be monitored is changed/deleted or added to 
an object. The trigger is not executed if the owner is deleted (e.g. device is deleted). 

If no attributes to be monitored are specified for the trigger definition, the trigger is not 
executed. The attributes to be monitored for the trigger definition are enclosed in angled 
brackets and separated by commas. 

Example:D:\exampleTrigger.vbs<Attribute_1,Attribute_2,...> 

Arguments are assigned to the trigger in the form of a tuple; each tuple can be interpreted as 
follows: 

• Attribute owner (e.g. sheet, device...) 
• Attribute name 
• Old attribute value 
• New attribute value 

Example of evaluating the tuple: 

Set e3 = CreateObject( "CT.Application" ) 
 Set prj = e3.CreateJobObject() 
  
 args = e3.GetScriptArguments 
 cnt = 0 
  
 For Each arg in args 
     modResult = cnt Mod 4 
     cnt = cnt + 1 
  
     If modResult = 0 Then 
          e3.PutInfo 0, "Attribute owner: " & arg  
     ElseIf modResult = 1 Then 
          e3.PutInfo 0, "Attribute name: " & arg 
     ElseIf modResult = 2 Then 
          e3.PutInfo 0, "Old value: " & arg 
     ElseIf modResult = 3 Then 
          e3.PutInfo 0, "New value: " & arg 
     End If  
 Next 
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 Set prj = Nothing 
 Set e3 = Nothing 

  

The trigger can set a return value using the function e3.SetTriggerReturn(). The following 
return values are possible: 

 

Value Symbol Name Meaning for BeforeModifyAttribute 

1 (Default) 

6 

vbOK 

vbYes 

The attribute modifications have been implemented. 

4 

2 

3 

5 

7 

vbRetry 

vbCancel 

vbAbort 

vbIgnore 

vbNo 

All modifications are rejected. 

. 
    

Note: No other values can be set with e3.SetTriggerReturn() or returned with 
e3.GetTriggerReturn(). 

  

Reference(s): Designer-26028 

Enhancement to ComponentInterface for Returning the Defined View Symbols of a 
Component with Their User-Specific View Numbers 

There is the following new COM command in the ComponentInterface: 

• ret = comp.GetViewDefinitions ( viewDefinitions ) 
o ret Number of definitions returned 
o viewDefinitions Two-dimensional array with the existing view information 

 1. Column = Symbol ID 
 2. Column = User-defined view number; 0 if no user-defined view number is 

defined. 

Example: 
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Symbol ID User-Defined View Number 

35876 0 

35446 5 
34923 33 

. 
  

The return value ret = 3 

  

Reference(s):Designer-26026 

New Trigger AfterConnectMUProject 

The trigger is executed when first opening a multi-user project and accessing a multi-user 
project. 

The trigger is always called up with 3 parameters: 

• 1. Parameter: The following values are possible: 

o "Create" when creating a multi-user project 
o "Open" when opening a multi-user project 
o "Delete" when deleting a multi-user project 

• 2. Parameter: The following values are possible: 

o 1 for the first user, which opens the multi-user project 
o 0 for all others with access 

• 3. Parameter: Name of multi-user project 

  

Reference(s): Designer-16579 

Enhancement to JobInterface for Displaying a List of Drawing Elements in a 
Predefined Color with PDF Export 

In the JobInterface there is the following new COM command: 

• ret = job.ExportPDFEx ( file, shtids, options, itemListType, items, 
alternativeColour, imageBrightness [,password] )  

o The parameters 'file, shtids, password' are the same as job.ExportPDF 
o options has changed as follows (this is also valid for job.ExportPDF):  

 &h0000 Default Acrobat version (currently 8) 
 &h0004 n/a: Version 4 no longer supported 
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 New: 
 &h0008 Acrobat Version 8 
 &h0009 Acrobat Version 9 
 &h000A Acrobat Version 10 

o The following parameters have been added: 

 itemListType Flag How the objects shall be output: 

 0 All objects, which are NOT in the items list, receive the specified 
color (alternative color) and (brightness) 

 1 All objects in the item list receive the specified color (alternative 
color) and brightness. 

 items List with objects (object numbers) from the E3 project 
 alternativeColour Color, which the objects shall receive (0 up to and 

including 255).  
 imageBrightness Brightness, which the images shall have. 

This can be a whole number between -100 and 100 (the smaller the number 
the darker; the larger the number the brighter).  

o ret The following return values are possible:  

 1 Export successful 
 -1 Unknown error 
 -2 No project opened 
 -3 Missing license 
 -4 Invalid file path or missing authorization 
 -5 Invalid sheet 
 -6 Invalid Acrobat version 
 -7 Invalid object list type 
 -8 Invalid color (outside of value range) 
 -9 Invalid luminosity (outside of value range) 
 -10 Invalid password 

  

Reference(s): Designer-25588 

Enhancement to SymbolInterface for Returning Duplicate Attribute Text Template 
Symbols whose Polygon Points refer to Origin's Coordinates 

There is the following new COM command in the SymbolInterface: 

• ret = sym.GetPlacedPolygon ( npnts, xarr, yarr ) 

o Valid for duplicate attribute text template symbols 
o npnts Number of polygon points, e.g. 4 points for a rectangle 
o xarr, yarr Arrays with x/y coordinates of polygon points;  

arrays start with 1 
o ret The return value is 1 if successful, otherwise 0. 

  

Reference(s): Designer-24834 
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Enhancement within the PinInterface to set the maximum number of connections on 
a pin 

There is the following new COM command in the PinInterface: 

• ret = pin.SetPhysicalMaxConnections( conncount )  

o Sets the max. number of connections for this pin 
o conncount is the max. number of connections for this pin 
o Possible return values for ret see above list 

 0 = Number has been set successfully 
 -1 = Number hasn't been set 
 -2 = No project opened 
 -3 = Invalid Pin 
 -4 = Invalid Number 

Restrictions: 

• The pin must have a component assigned. 
• The pin must have a physical description. 
• When the Use signal equivalence (to select connect pin) option is checked in 

Settings... -> Connection -> Conductors/Wires, a physically described pin must 
exist with the same pin index. 

Note: 

• The highest possible number is set to 999 

  

Reference(s): Designer-26833 
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Connections/Buses, Signals/Logic Lines, Supply  - Overview 

• Conductor Logic Lines 
o Conductor Logic Lines Can Now Be Displayed for Selective Signals 
o Logic Lines of Not Connected Conductors Can Now Be Displayed as Arcs 

• New Functionality in E3 'Reorder Conductors' 
• New Functionality in E3 'Signal Format'  
• Misc 

o Alternative Template Symbol Can Now Be Defined in the Settings 
o New Check Box in Settings for Deleting Signals of Not Connected View 

Symbols 
o Define whether the Signal on a Pin Shall Be Removed when Unconnecting 

Conductors/Wires on a Pin 
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Logic Lines 

• Conductor Logic Lines Can Now Be Displayed for Selective Signals 
• Logic Lines of Not Connected Conductors Can Now Be Displayed as Arcs 

Conductor Logic Lines Can Now Be Displayed for Selective Signals  

Previously, when the check box Display laid conductors also in the Settings under 
Connection - Cable/Conductor Logic Lines) in the section Cable/Conductors ) was 
checked, all conductor logic lines project-wide were displayed:  

 

 With this new option the user can now display the individual conductor logic lines of a signal 
on a pin or optionally all signals of a device. This enables the signal to be traced more easily 
over several sheets. 

To do so, there are the following new icons in the Display toolbar: 

•  Display signal(s) 
or alternatively by pressing the F6 key 

•  Reset display signal(s) 
 or alternatively by pressing the key combination SHIFT+F6 

Note: 

• At least one wire must be placed on the connection line. 
• This functionality is inactive on panel sheets. 
• When closing a project or reading/writing an E3D design file, already displayed conductor 

logic lines are not saved.  
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Display Conductor Logic Lines of Signal on a Pin 

To display the conductor logic lines of a signal on a pin: 

• left-click on the icon  Display signal(s) 
or press the F6 key, 

• left-click with the mouse pointer on the area in front of the individual pin (all pins which 
are connected to a conductor/wire): 

 

Note:   

• The conductor logic lines of the signals used (in the example the signal #7) are 
displayed project-wide. 

• This functionality is also available in the Device Tree and the Pin Table: 
o right-click on the desired pin symbol (multi-select also possible) and then select 

the context menu command Highlight Conductor Logic Lines of Signal 
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Display Conductor Logic Lines of All Signals on a Device 

To display the conductor logic lines of all signals on a device: 

• left-click on the icon  Display signal(s) 
or press the F6 key, 

• then left-click on a device symbol using the mouse pointer: 

 

Note: 

• The conductor logic lines of the signals used (in the example the signals #7, #8, #9, 
#10) are displayed project-wide. 

• This functionality is also available in the Device Tree and Device Table: 
o right-click on the desired device-symbol (multi-select also possible) and then select 

the context menu command Highlight Conductor Logic Lines of Signal 

 Display Conductor Logic Lines of Signal using Signal Tree 

To display the conductor logic lines of a signal using the signal tree: 

• right-click on the desired symbol in the signal tree (multi-select also possible), 
• then select the context menu command Highlight Conductor Logic Lines of Signal: 

Note: The conductor logic lines of the selected signal are displayed project-wide. 

  Suppress Conductor Logic Lines of All Signals 

To suppress the conductor logic lines of all signals: 

• left-click on the icon  Reset display signal(s) 
or press the key combination SHIFT+F6 

 Display Already Displayed Conductor Logic Lines 

There is also the possibility to display already displayed conductor logic lines. 

To do so, activate the new check box Keep existing conductor logic lines of signal in the 
section Conductor Logic Lines of Signal in the Settings under Connection - 
Cable/Conductors Logic Lines: 
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Cable/Conductor Logic Lines 
 

 Conductor Logic Lines of Signal   

Keep existing 
conductor logic 
lines of signal 

If this option is checked, the displayed signal logic lines are retained. 

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
KEEP_EXISTING_CORE_LOGIC_LINES_OF_SIGNAL 

This check box is user-specific in a multi-user project. 

. 
 

For this there are the following new COM commands in the SignalInterface and 
JobInterface: 

• sig.HighlightCoreLogicLinesOfSignal ()  

o Display all conductor logic lines of a signal 

• job.ResetHighlightCoreLogicLinesOfSignals ()  
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o Reset the display of all conductor logic lines of all signals 

  

Reference(s): Designer-25376 

Logic Lines of Not Connected Conductors Can Now Be Displayed as Arcs 

Previously, the logic lines of not connected conductors (without connection line) were always 
displayed as straight lines: 

 

Now these logic lines can also be displayed as arcs: 

 

To do so, there is the new check box Display conductor logic lines as arcsin the Settings 
under Tools -> Settings -> Connection -> Cable/Conductor Logic Lines in the section 
Lines.  

Note: The section Lines has been enhanced for the already existing options Line style and 
Mark direction. 
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Cable / Conductor Logic Lines 
 

Display 
conductor logic 
lines as arcs 

When this option is active, all logic lines of unconnected conductors are 
shown as arcs. 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_namecan be used: AIRLINES 

This check box is user-specific in a multi-user project. 

. 
 

  

Reference(s): Designer-25502 
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Functionality 'Reorder Conductors' 

• New Functionality in E3 'Reorder Conductors' 

New Functionality in E3 'Reorder Conductors' 

Previously, already connected conductors could only be reordered by executing the command 
Reconnect Conductors. Now conductors can be reordered within a connected conductor logic 
line segment (multiple conductors within a connection net) using the mouse pointer.  

To do so, there is the new  Reorder conductors icon in the Toolbar - Category Connect. 

  

Note: The conductor logic lines must be visible for this function. 

  

How to change the connection order of conductors: 

• Left-click on the icon  Reorder conductors, 
• the mouse pointer appears in the form of an open hand in the workspace, 
• click on the desired end of the conductor logic line which shall be reconnected: 

 
Note: The hand closes as soon as the core logic line is positioned within the snap area: 

 
• Left-click on the pin where the conductor shall be reordered.  

 47  
  



 

• All possible pins are identified by hash key symbols "#":  

 
• Note: 
• If necessary, additional conductor logic lines can be reordered accordingly after 

executing the command. 
•  After reordering all desired core logic lines, right-click anywhere within the work space  
• the following context menu commands are available: 

o End  
The command ends but keeps previous changes. 

o Abort 
The command ends and rejects all changes made. 
The command can be terminated with the ESC tab.  

Note: 

• Once the pin no longer has contact to the previous core route, an appropriate message 
appears. 

• If there is a conflict with the connection restrictions when connecting a core/wire to pin 
(e.g. max. number of cores/wires), an appropriate warning message appears in the 
status bar. The pin is marked with an exclamation point while the command is open. 

• If pins violate the pin restrictions, an appropriate warning message will appear 
after executing the command Reorder conductors.  

• The command Reorder conductors can only be canceled if the pin restrictions 
have been considered. The command can be undone optionally. 

• While executing the command Reorder conductors, the context menu command Open 
End can be selected after right-clicking anywhere within the workspace. Then, the 
conductor logic line has an open end (temporarily). 

  

Reference(s): Designer-25415 
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Functionality 'Signal Format' 

• New Functionality in E3 'Signal Format' 

 New Functionality in E3 'Signal Format'  

In E3.series a signal placeholder for the signal name can now be displayed on the signal. The 
signal name will automatically be generated either for one-time use or for relevant changes 
according to the format description after having placed a signal placeholder. Placing the signal 
placeholder occurs with the new functionality Signal Format. 

How to place a signal placeholder in a signal text: 

• right-click on the desired connection line and select the command Signal Format...in 
the displayed context menu 
or 
right-click with the mouse button on the desired signal within the signal tree and select 
the command Signal Format... in the displayed context menu 
or 
right-click on the desired symbol in the working area and select the command Signal 
Format... in the displayed context menu. 

• the Signal Format dialog opens: 

 

 

Signal Format 
 

Format: The signal placeholder can be entered on a signal here. 

 The following signal placeholders are available: 

• <.SHEET> 
If this signal placeholder is specified, the sheet name on which the 
reference object is placed appears as the signal name. 
Note: If the sheet name is numeric, it will be displayed with at least 
three digits and zeros at the beginning. 

• <.GRID> 
If this signal placeholder is specified, the current sheet coordinates on 
which the reference object is placed appear as the signal name. 
Note: The pin on the first sheet in the project structure with minimum X 
and maximum Y coordinate will be used as the reference object. 
The sheet coordinates are displayed according to the Setting Format: 
(in the section Settings under 'General -> Display -> Sheet 
Reference-> Format) 
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• <Attribute> 
If this signal placeholder is specified, a signal or a sheet attribute 
appears when available. 
Note: The attribute must contain 'Signal' or 'Sheet' as the valid owner. 
If both 'Signal' and 'Sheet' are available, the attribute is determined by 
the signal.  

Already created signal format combinations can be selected in the drop-down 
list. 

Note:   

• Additionally permitted characters can be placed before and after signal 
placeholders. The following characters are not allowed < > , { }. 
Example: 123_<.SHEET>-ABC 

• Up to eight signal placeholders can be used for a signal. In doing so, a 
signal placeholder may not appear repeatedly. 

• A signal placeholder must be unique. 

Examples of faults: 

• Different attributes used in the signal format have the same 
attribute value. 
(Example: Attribute 1 with entry A - Attribute 2 with entry A) 

• The signal name generated by the signal format is already used as 
signal name.  

• Exception: The signal name generated by the signal format <.GRID> 
from the sheet coordinates information is already used in another sheet. 
In this case the next possible free sheet coordinate will be used 
(Example: Instead of A1 -> A2). 

• Using <no entry> resets the signal format on the signal. 
• When determining the reference object, inactive objects are also 

considered for variants/options. 

Clicking the button  opens the Translation Table dialog. This dialog 
displays all entries of the different languages. 

The desired text is inserted. 

Recalculate 
signal name 
according to 
format 
specification 

If the check box is active, all relevant changes to the signal formats will be 
recalculated automatically. In doing so, it's possible to control whether 
modifications to each signal can be individually updated or not. 

Relevant changes are: 

• Moving a sheet within the project structure if the reference object is 
changed. 

• Moving connection lines or symbols if the reference object is changed. 
• Changing an attribute value which is used as the signal format. 
• Deleting signals 
• Deleting or moving reference objects 

A default value can be defined using the new check box Recalculate signal 
names according to format specification in the Settings (under 
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'Connection -> Signals -> Signal Format): 

 

  

. 
 

Note:  It's also possible to set signal placeholders in texts of the type TTYP_SIGNAL (#7) 
and TTYP_CONNECTION_SIGNAL (#1007) as follows: 

• by selecting the signal texts and clicking F2 afterward, or 
• right-clicking on the signal text and selecting the command Text Properties... in the 

displayed context menu. 
Select the tab Text in the Text Properties and insert the desired signal placeholder 
under Text. 

  

Example for the signal placeholder <.SHEET>: 

1. This example shows the sheet name 'sheet_name': 
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2. The signal placeholder <.SHEET> is defined on the signal: 

 

  

3. The signal now receives the current sheet name 'sheet_name' as signal name: 

 

  

  

Example for the signal placeholder <.GRID>: 

1. 'C2' is used as reference value for the sheet coordinate in following example : 

 

2. The signal placeholder <.GRID> will be defined on signal: 

 

3. Now the signal receives the sheet coordinate 'C2' as signal name: 
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 Example for the signal placeholder <ATTRIBUTE>: 

1. The signal attribute 'New Feature' is used as attribute with the Entry 2014': 

 

2. The signal placeholder <New Feature> (<Name of attribute>) is defined on the signal: 

 

3. The signal now receives the Entry 2014' from attribute Demo' as the signal name: 

 

  

Reference(s): Designer-25414  
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Misc 

• Alternative Template Symbol Can Now Be Defined in the Settings 
• New Check Box in Settings for Deleting Signals of Not Connected View Symbols 
• Define whether the Signal on a Pin Shall Be Removed when Unconnecting 

Conductors/Wires on a Pin 

Alternative Template Symbol Can Now Be Defined in the Settings 

In E3.series an alternative template symbol can now be defined. When placing a conductor 
template symbol on a connection line, the alternative template symbol can be used. 

 To do so, there is the new section Alternative Template Symbol in the category 
Connection. A horizontal or vertical alternative template symbol can be defined here using 
the respective drop-down list: 
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Connection 
 

Alternative 
Template 
Symbol 

This option determines, which alternative template symbol shall be used 
when placing a conductor template symbol or a conductor on a connection 
(dragging & dropping a conductor). Depending on whether the connection 
line is horizontal or vertical, the corresponding symbol is placed. 

Note: By pressing the Alt or Alt Gr key the alternative template symbol 
can be used for the following commands: 

o when placing a connection template symbol  
(symbol Place connect template symbol in the Placement toolbar) 

o when placing conductors/wires  

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used:  

• Horizontal: WCOUNT_SYMBOL_HOR_ALT 
• Vertical: WCOUNT_SYMBOL_VER_ALT 

The alternative template symbol is user-specific in a multi-user project. 

  

. 
 

  

Reference(s): Designer-25605 

New Check Box in Settings for Deleting Signals of Not Connected View Symbols  

Previously, signals were only deleted in E3.series when the check box Clear signals when 
deleting symbols was checked if there were no placed views of the corresponding device and 
no connected conductors. From now on signals can also be deleted if there are unconnected 
view symbols of this device. 

To do so, there is a new check box Even if not connected view symbols are placed in the 
section Signals on Symbols under the category Connection - Signals in the Settings: 
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Connection - Signals 
 

Even if not 
connected view 
symbols are 
placed  

Note: This check box can only be activated/deactivated if the check box 
Clear signals when deleting symbols is checked. 

When the check box is checked and symbols are deleted, the signals are 
also deleted if there are unconnected view symbols of this device. 

Note: The signal is not deleted if...  

• the original device symbol is placed 
• a device view with a graphical or physical connection is placed on the 

pin. 
• a device view is placed and the pin is connected to another device 
• the signal is also routed on a topology sheet 
• a device view is placed and a wire is connected to the pin. 

Prerequisite: The check box "Unconnect, when no graphical 
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representation is not active. (Not active in the Settings in the 
Category Connection in the section Conductor/Wires". 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
CLEAR_SIG_ON_PLACED_VIEW_SYMBOL 

This check box is user-specific in a multi-user project. 

. 
 

Reference(s): Designer-26078 

Define whether the Signal on a Pin Shall Be Removed when Unconnecting 
Conductors/Wires on a Pin  

It's now possible to define whether the signal on a pin shall be removed when unconnecting 
conductors/wires on a pin.  

Note: This is only valid if no additional conductors/wires and/or graphical connections are 
located on this pin and its pin views.  

 To do so, there is the new check box Clear signal after unconnect conductor/wire at 
unconnected pin in the Settings under the category Connection in the section 
Conductors/Wires: 
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Connection 
 

Clear signal 
after unconnect 
conductor/wire 
at unconnected 
pin 

If this check box is active, it checks to see whether additional 
conductors/wires are located on this pin when unconnecting a 
conductor/wire on a pin.  

If no additional conductors/wires and/or graphical connections are placed 
on the pin and its pin views, the signal is removed. 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used:  

CLEAR_SIGNAL_AT_PIN_AFTER_UNCONNECT_CORE 
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This check box is user-specific in a multi-user project.  

. 
 

Reference(s): Designer-25957 
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Connectors 

• Connector Pins Can Now Be Placed as Single Pins when Changing a Component 
or Updating a Project  

• User-Defined View Numbers for Connector Views 
• New Options for Assigning Numbers to Connectors and Mating Connectors in 

the Settings 

Connector Pins Can Now Be Placed as Single Pins when Changing a Component or 
Updating a Project  

In E3.series it's possible to control whether the connector pins shall be placed as single pins 
when 

• updating the project, or  
• changing a component  

To do so, there is the check box Place all pins as single pins available in the following 
menus: 

• In the category General - Update in Project the section Connectors 

 

 60  
  



 

• and in the category Placement - Change Component the section Connectors 

 

 

  General - Update in project  Placement - Change Component  
 

Place all 
pins as 
single 
pins 

  

If this check box is checked, the connector pins are placed as single pins when  

•  changing a component or 
• updating a project 

 The old connector will be deleted and the new connector placed as single pins. 
The former position of the first (displayed) pin will help as indication. Existing 
spaces will be ignored and deleted when placing newly. Otherwise, the same rules 
apply as when interactively placing the entire connector as single pins. 

Prerequisite: 

If all connector pins 

•  are placed as single pins  
• have the same direction vector 
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• are placed without being interrupted by a symbol of another device  

 If the new connector has a different number of pins or symbols (with a feed 
through connector) as the previous connector, the following is valid:  

• New pin symbols are placed automatically 'in addition'  
• Symbols of no longer used pins are deleted automatically 

Note:   

• No difference is made between the original and the device view of the 
connector  

• A group of symbols remains if all pins are part of the group 
• Inserts are treated as general connectors at configurable connectors. 

If the check box is not checked or the prerequisites are not fulfilled, the connector 
pins are handled like previously when  

•  changing a component or 
• updating a project 

  

For the COM methods 
prj.GetSettingValue and 
prj.SetSettingValue the following 
setting_name can be used: 

UPDATE_PLACE_SINGLE_PINS 

The check box is project-specific in a 
multi-user project. 

For the COM methods 
prj.GetSettingValue and 
prj.SetSettingValue the following 
setting_name can be used:  

CC_PLACE_SINGLE_PINS 

The check box is project specific in a 
multi-user project. 

  

. 
 

  

Reference(s): Designer-26110 

User-Defined View Numbers for Connector Views 

Previously in E3.series a view number could only be defined for normal device views. From 
now on a user-defined view number can be specified for connector views.  

To define the view number, there is the new input field User defined view number in the 
Symbol Properties in Database Editor Mode: 

This option is only available if a view on component sheet has been selected! 
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Symbol Properties 
 

User defined 
view number 

If the check box is checked, a user-defined view number can be specified 
for the view. This also appears in the tool tip view: 

 

If the check box is not checked, a ? is displayed instead of the user-defined 
view number. 

. 
 

  

If a device view is placed on a sheet in the project with the attribute .PREFERRED_VIEW, the 
user-defined view number appears after the symbol name (…#17). 

(See 'New View' and 'Place on Formboard' Dialogs Have Been Enhanced) 
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If one opens the device view's Device Properties, the user-defined view number is displayed in 
the field Created with the view number:: 

 

Reference(s): Designer-26026 

New Options for Assigning Numbers to Connectors and Mating Connectors in the 
Settings 

In E3.series there are some new options for assigning numbers to connectors and mating 
connectors.  

To do so, there are the following new functions in the Settings under the section Device 
Designation Generation in the category Connection - Connectors: 
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Connection - Connectors 
 

Device designation Generation  
  

Use same 
numeric part 
for connector 
and mating 
connector 

If this option is active, the following is valid: 

When placing a mating connector, it tries to use the same device 
designation as the corresponding connector. 

Note: If it already has the same device designation (same letter code), 
then _<nnn> is also added. This ensures that the device designation is 
unique by adding <nnn>. 

If the device designation of a connector in the plugged state is changed, 
the number of the mating connector is changed as well so that they both 
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have the same number. 

  

Example with different letters: 

connector: -X1<--> mating connector: -B1 (letter B) 

Example with same letters: 

connector -X1 <--> mating connector: -X1_1 (letter X) 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
USE_SAME_NUMERIC_PART_FOR_MATING_CONNECTOR. 

This check box is project-specific in a multi-user project. 

Use automatic 
connector 
naming 

If this option is active, a default designation must be defined for the 
connector and mating connector in the text fields Default designation for 
plugs:and Default designation for jacks:.  

If a connector has a defined default designation, the defined default 
designation for the jack is used automatically when generating the mating 
connector. This is independent of which default designation has been 
defined in the database for the connector.  

Note: If the numerical part of a connector is changed later, the numerical 
part of the mating connector is also correspondingly changed. 

  

Examples: 

Default designation for connector: P 

Default designation for mating connector: J 

  

connector: -P1 <--> mating connector: -J1 

connector: -J100 <--> mating connector: -P100  

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
USE_ANSI_STANDARD_FOR_MATING_CONNECTOR. 

This check box is project-specific in a multi-user project. 

  

Default 
designation for 

Note: This text field can only be edited if this check box Use automatic 
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plugs: connector naming is checked. 

In this text field a default designation can be defined using a standard 
value. 

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
DEFAULT_DESIGNATION_FOR_PLUGS. 

This check box is project-specific in a multi-user project. 

Default 
designation for 
jacks: 

Note: This text field can only be edited if this check box Use automatic 
connector naming is checked. 

In this text field a default designation can be defined using a standard 
value. 

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
DEFAULT_DESIGNATION_FOR_JACKS. 

This check box is project-specific in a multi-user project. 

  

. 
 

  

Reference(s): Designer-15125, Designer-26201 
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Fluid 

• 'Electric Settings' and 'Fluid Settings' Can Now Be Called Up in the Settings 
• Special Options with Separate Values for the Respective Discipline 
• Enhancement to JobInterface: COM Command 'SetDisplayConnectPoints' with 

Own Settings for Fluid 

'Electric Settings' and 'Fluid Settings' Can Now Be Called Up in the Settings  

From now on the settings in E3.series are separated into 'Electric Settings' and 'Fluid 
Settings'. From a functionality standpoint these setting dialogs are nearly identical. They only 
differ in that the functions and terms correspond with the respective discipline.  

 Using the main menu the desired settings can be called up:  

• The electric settings are called up using Tools -> Electric Settings.... 
• The fluid settings are called up using Tools -> Fluid Settings....  

The settings can also be called up in the main menu under Tools -> Settings... or by pressing 
the hot key S.  

If one of the following schematic types... 

• Electric 
• Process, measurement and control 
• Panel Symbol 
• Tubes + Instruments 
• Single Line Diagram 

is checked in the Sheet Properties of the active sheet, the Electric Settings open. 

If the schematic type 'Hydraulic' and/or 'Pneumatic' is selected in the Sheet Properties of 
the active sheet, the Fluid Settings open. 

Special Options with Separate Values for the Respective Discipline 

 Furthermore, there are special options in the settings, in which the defined value can be 
handled separately and saved for the respective discipline. These option are identified by italics 
in the Settings:  

• Grid size (General) 
• Snap size (General) 
• Mark unconnected nodes (General - Display) 
• Internal/ external / jumper / seal representation for nodes (General - Display) 
• T-Connections (General - Display) 
• Forced wiring (electric) / Forced connections(fluid) General - Display) 
• Open line end (General - Display) 

  

Note:   

All other options in the settings (with normal typeface) are globally valid for both disciplines. 
Even if they have designations which differ partly: 
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Enhancement to JobInterface: COM Command 'SetDisplayConnectPoints' with Own 
Settings for Fluid 

The following COM command in the JobInterface has been enhanced: 

• ret = job.SetDisplayConnectPoints ( newval ) 

o newval The following values can be combined: 

 &H01: Pins are displayed in connection nets for T-connections and forced 
wiring. (Electric and now Fluid) 

 &H02: Pins are displayed in connection nets for T-connections. (Electric) 
 &H04: Pins are displayed in connection nets for forced wiring. (Electric) 
 &H08: Pins are displayed in connection nets for open line ends. (Electric) 
 &H10: Pins are displayed in connection nets for T-connections. (Fluid) new 
 &H20: Pins are displayed in connection nets for open line ends. (Fluid) new 
 &H40: Pins are displayed in connection nets for forced wiring. (Fluid) new 

o ret The return value is the previous setting. 

These values are also valid for the return value of the COM command 
job.GetDisplayConnectPoints 

  

Reference(s): Designer-26179 
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Formboard 

• New Options for Inserting Nodes using the Formboard Dialog 'Add Node' 
• Pins without Placed Conductors/Wires Can Now Be Displayed in the Formboard 

Connector Table 
• Two Additional Possibilities Now for Automatically Routing Wires Assigned 

Options in Formboard 

New Options for Inserting Nodes using the Formboard Dialog 'Add Node'  

In the Add Node dialog there is the new section Node Properties: 

Note:   

• Previously, the selection fields Segment-splitting node/Segment-merging node as 
well as the check box Lock node were only context menu commands.  

• The defined settings in the Node Properties remain unchanged when calling up the 
dialog again. 

 

 

Add Node 
 

Node Properties  
  

Segment-
splitting Node 

This command is only active on a connected node of a segment. The 
appropriate segments are disconnected from each other afterward. 

Segment- This command is only active on a disconnected node of a segment. The 
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merging Node appropriate segments are afterward connected to each other.  

Lock Node This command is active on nodes. The selected node is locked. As soon as a 
node has been fixed, it is shown grayed-out. A locked node will not be 
deleted when an added connection is deleted. 

  

. 
 

  

Reference(s): Designer-25617 

Pins without Placed Conductors/Wires Can Now Be Displayed in the Formboard 
Connector Table   

Previously, when the check box Display one row for each conductor (called up using Tools 
-> Settings -> Formboard in the section 'Connector Table) was checked, no pins without 
placed conductors/wires were displayed in the Formboard Connector Table. With the new 
functionality it's now possible to independently control whether pins without placed 
conductors/wires are displayed in the Connector Table. 

To do so, there is the new check box Display pins without conductors under the category 
Formboard in the Settings: 
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Formboard 
 

Connector Table  
  

Display pins 
without 
conductors 

If this option is checked, at least one row is displayed for every pin in the 
Formboard Table. 

If this option is not checked, only pins with placed conductors/wires are 
displayed in the Formboard Table. 

Note: This option is checked by default. 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
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FORMBOARD_TABLE_DISPLAY_PINS_WITHOUT_CORES. 

This check box is user-specific in a multi-user project. 

. 
 

  

Reference(s): Designer-18208 

Two Additional Possibilities Now for Automatically Routing Wires Assigned Options in 
Formboard  

In total there are now three possibilities for automatically placing (routing) wires/conductors 
that are assigned options in formboard.  

Note: To do so, the check box Show information for option combinations must be 
checked (in the settings under Tools -> Settings -> Connection -> Conductors/Wires in 
the section Conductor Assignment Procedure. 

  

Case 1: Routing Wires using Cable Harness Derivatives  

Previously, cable harness derivatives were assigned directly to net segments. Wires with an 
appropriate option were automatically routed through these net segments. 

 

Case 2: Routing Wires using Options (indirectly through cable harness derivatives) 

Due to the fact that numerous cable harness derivatives are available in larger projects, 
routing wires directly may be extremely difficult to manage. That is why this routing method is 
recommended. 

An option can now be assigned to a formboard net segment instead of a cable harness 
derivative. For this option all appropriate cable harness derivatives are determined 
automatically. 

The wires are routed as if the determined cable harness derivatives have been assigned to the 
segment. 
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Case 3: Routing Wires using Options (without cable harness derivatives)  

If no appropriate cable harness derivative is found in the project, the automatic routing of 
wires takes place using options. For this the option combinations on the wires and net 
segments must be identical: 

 

  

Reference(s): Designer-25427 
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Graphics / Dimensions 

• Three New Dimension Line Types Available 
• New Functionality 'Running Dimension'  
• Enhancements to DimensionInterface for Generating and Adapting Running 

Dimensions 
• Dimension Text of Running Dimensions Can Be Rotated 
• Enhancements to DimensionInterface for Displaying Dimension Text of Running 

Dimensions as Rotated 

Three New Dimension Line Types Available 

The following three new line types are available for dimension lines: 

 

Line 
type: 

Description: 

 
Extension lines with 
dimension line and forward 
slashes at the ends instead of 
arrowheads 

 
Extension lines with 
dimension line and no 
arrowheads 

 
Extension lines without 
dimension line and no 
arrowheads 

. 
 

The arrow types can be defined  

o by default in the Settings (under Tools -> Settings -> Dimension)  
o and individually in the Dimension Properties in the tab  Dimension 

 in the section Lines in the drop-down list Arrow:.  

Furthermore, the arrow width can now also be individually defined in the Dimension Properties. 

To do so, there is the field Arrow width: under the Dimension tab of the Dimension 
Properties: 
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Note: The set arrow width from Settings – Dimension will be used as default value when the 
option Setting Value is active. 

  

Reference(s): Designer-06049 

New Functionality 'Running Dimension'  

Previously, a dimension could only be defined using two reference points (from starting point 
to end point). It's now possible to define dimensions using several reference points. To do so, 
there is the new function 'Running Dimension'.  

  

To insert a running dimension: 

• select the command Insert -> Running Dimension in the main menu, or 
•  click on the new icon  Running Dimension in the Graphic toolbar 

For determining the dimension's starting point left-click on the desired location.  

 76  
  



 

For additional reference points simply left-click on the desired locations.  

The dimension texts are centered automatically. 

  

Note:  

The filled circle denotes the starting point and reference point of the dimension. From there the 
individual length specifications are calculated:  

 

To delete a running dimension: 

Parts of a running dimension can be individually deleted.  

Select the desired elements of the running dimension by left-clicking and pressing the SHIFT 
key and then press the DEL key. 

To select all parts of the running dimension, left-click directly on the first extension line at the 
starting point: 

 

Enhancements to DimensionInterface for Generating and Adapting Running 
Dimensions 

In the DimensionInterface there are the following new COM commands: 

  

• ret = dim.CreateEx ( dimtyp, sheet, x, y, flags ) 

o dimtyp The following dimension types are supported: 

 6 standard (horizontal or vertical) running dimension  
 8 angled running dimension 
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o sheet ID of sheet, on which the reference dimension shall be created 
o x, y Array of all x, y coordinates of the click points 
o flags currently not used 
o ret The following return values are possible: 

 >0 ID of running dimension if successful 
 -1 invalid dimension type 
 -2 invalid sheet 
 -3 invalid starting point 
 -4 invalid point 

• ret = dim.GetPartIds ( ids ) 

o ids Array with all IDs of part dimensions 
o ret Number of IDs 

• ret = dim.IsPartOfDimension 

o ret The return value is 1 if dim is a part of the running dimension, otherwise 0. 

• ret = dim.IsRunningDimension 

o ret The return value is 1 if it's a running dimension, otherwise 0. 

Dimension Text of Running Dimensions Can Be Rotated 

The dimension text of running dimensions can be rotated 90°: 

 

 To define the dimension text as rotated for all running dimensions by default, use the new 
check box Rotate texts of running dimensions: in the Settings under Tools -> Settings -
> Dimensions in the section Text: 
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Dimensions 
 

Rotate texts of 
running 
dimensions:  

If checked, the dimension text of running dimensions is rotated 90°. 

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
DIM_ROTATE_TEXT_OF_RUNNING_DIM. 

This check box is user-specific in a multiuser project. 

. 
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Rotating the text of running dimensions can be specified later using the Dimension 
Properties: 

 

 

Dimension Properties - Dimension  
 

Rotate texts of 
running 
dimensions:  

If checked, the dimension text for running dimensions is rotated 90°. 

  

. 
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 Enhancements to DimensionInterface for Displaying Dimension Text of Running 
Dimensions as Rotated 

In the DimensionInterface there are the following new COM commands: 

• ret = dim.GetRunningDimTextRotation  

o ret The return value can have the following values:  

 -1 The function cannot be executed on this type of dimension. 
 0 The dimension text is not rotated. 
 1 The dimension text is rotated. 

  

• ret = dim.SetRunningDimTextRotation ( value )  

o value The following values are possible:  

 0 The dimension text is not rotated. 
 1 The dimension text is rotated. 

o ret The return value is 0 if successful, otherwise -1. 

  

Reference(s): Designer-03804, Designer-25881 
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Import/Export (subcircuits) 

• Connection Direction of Conductors/Wires Can Be Ignored when Importing 
Subcircuits  

• DWG/DXF Import/Export Now Compatible with AutoCAD Version 2013 

Connection Direction of Conductors/Wires Can Be Ignored when Importing 
Subcircuits 

Previously when importing subcircuits, the connection direction of placed conductors/wires was 
checked automatically (from pin to pin). 

 If the conductors/wires in the subcircuit had different connection directions as elements 
already used in the project, new elements were generated for 

• conductors/wires 
• cables 

This can be prevented by now ignoring the connection direction when importing a subcircuit. 
To do so, there is the new check box Merge ignoring conductor direction. 

The check box Merge ignoring conductor direction can be defined by default in the 
Settings under Tools -> Settings -> Placement -> Import - Device in the section 
Additional Merge Options :  
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Devices 
 

Merge ignoring 
conductor 
direction 

If checked, the connection direction of conductors/wires is ignored when 
merging a drawing or subcircuit.  

  

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: 
MERGE_IGNORING_CONDUCTOR_DIRECTION 

This check box is user-specific in a multi-user project. 

. 
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The check box Merge ignoring conductor direction can be alternatively defined when 
importing a drawing File -> Import -> Drawing... -> Options.... 

Note: After clicking OK, the check box is changed accordingly in the Settings (and vice-versa). 

 

  

Reference(s): Designer-23119 

DWG/DXF Import/Export Now Compatible with AutoCAD Version 2013  

DWG/DXF Import/Export is now also compatible with AutoCAD Version 2013. 

In the Export DWG/DXF Files dialog (called up using File -> Export -> DXF/DWG...) there 
is the new entry Acad 2013 in the Export version: drop-down list: 
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Reference(s): Designer-23294 
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Panel 

• New Section '2D View Options' in 'Insert New Sheet' Dialog in E3.panel  
• Already Placed 2D Views Can Now Be Deleted 
• Symbol Properties Can Now Be Opened when Placing Models on Panel Sheets 
• New '3D View' Toolbar in Panel 
• Models Can Now Be Set as Transparent or Invisible in the 3D View 

New Section '2D View Options' in 'Insert New Sheet' Dialog in E3.panel 

Previously, a new 2D view sheet was generated automatically when creating a 2D View. Now 
new 2D views can be added to already existing 2D view sheets. 

To do so, there is the new section 2D View Options in the Insert New Sheet dialog: 

Note:   

• The section 2D View Options only appears in the dialog window if the context menu 
command Create 2D View... has been executed. 

 

 

Insert New Sheet 
 

2D View Options 
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Add to 
existin
g 2D 
view 
sheet 

  

The check box can only be activated if a sheet with a 2D view already exists. If the 
check box is inactive or no 2D view exists, a new 2D view sheet is created. 

If the check box is checked, an already existing 2D view sheet can be selected 
within the drop-down list on which the new 2D view shall be added. 

  

Under Preview the cutout of the 2D view can be adapted to 

• the size (press and hold left mouse button on upper right corner) 
•  the position (press and hold left mouse button on the cutout)  

  

 

  

  

Create 
new 
model 
view 

The following definitions can be found after creating a 2D view of a model (and 
placed models on it): 

• If the check box is active, the model is displayed both on the former sheet (on 
which the model is placed) and the new 2D view sheet. 

• If the check box is inactive, the model will be switched to the 2D view sheet. 

  

  

Scale: Here, the option 'Automatic' has been added to the drop-down list. 
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If 'Automatic' is selected, the scale will be calculated according to the cutout. 

. 
 

  

Note:   

When importing panel sheets, it tries to merge models with 2D views.  
The following is valid:  

• Only one 2D view per model  
• Models and 2D views may not differ regarding the following points: 

 Position 
 Length (mounts, cable ducts) 
 Rotation/Tilting 

  

When importing, panel sheets are no longer moved to a new position. This is valid for all 
imported panel sheets (not only 2D views).  

Exceptions: 

• If models/2D views collide and they cannot be inserted at the respective position 
• By executing the command Paste Extended, the subcircuit sheets are moved to a new 

position. 

  

Already Placed 2D Views Can Now Be Deleted 

If there are several 2D views on a 2D view sheet, the 2D view can be deleted using the new 
context menu command Delete 2D View. 

How to delete a 2D view on the 2D view sheet: 

• right-click on the 2D view and select the command within the displayed context menu 
Delete 2D View,  

• the 2D view is deleted on the 2D view sheet 

  

Reference(s): Designer-09310 

Symbol Properties Can Now Be Opened when Placing Models on Panel Sheets  

It's now possible to open the Symbol Properties of models placed on panel sheets. 

The tilting direction for the model symbol is displayed in curly brackets in the line Symbol 
name in the Symbol Properties.  

Example: Symbol name: {Front} 
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Reference(s): Designer-19341 

New '3D View' Toolbar in Panel 

In E3.panel it's now possible to rotate the respective view of an object when the 3D display 
mode is active. 

The following symbols are available in the new toolbar '3D View' : 

 

 

Symbol: Purpose: 

 Top 
Displays the top view 

 Bottom 
Displays the bottom view 

 Left 
Displays the left view 

 Right 
Displays the right view 

 Front 
Displays the front view 

 Back 
Displays the back view 

 Isometric 
Displays the view in isometric 
axonometric 

 Dimetric 
Displays the view in dimetric 
axonometric 

 Animation 
After changing the view an 
animation occurs 
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. 
 

Note: 

The toolbar is not displayed by default. 

The toolbar can be displayed by: 

• selecting Tools -> Customize -> Tab Toolbar , 
• clicking Toolbars: and choosing 3D View in the list 

or  

• right-clicking within the area of toolbars and 
•  marking the 3D View. 

  

This functionality is also available within the Preview Window of the following dialogs:  

• Device Properties - Shape 
• Device Properties - Slots/Pins 
• Device Properties - Restricted 
• Model Properties - Shape 
• Model Properties - Slots/Pins 
• Component Table 

To do so, right-click anywhere in the Preview Window: 

 

  

References: Designer-23135 
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Models Can Now Be Set as Transparent or Invisible in the 3D View  

In the 3D display models and their mounted devices can now be set as 'Transparent' or 
'Invisible'. In doing so, panel doors or miscellaneously placed elements can be made invisible 
in a closed panel so that one has a better view of the desired area.  

Note: 

• Connections on panel sheets cannot be set as 'Transparent' or 'Invisible' 
• When importing subcircuits or using Cut&Paste/Copy&Paste, the state is set to visible 

once again. 

 

  

To realize this functionality, there is the new context menu command Transparency in 3D.  

Prerequisite: This is valid for the following models:  

• For all models in the tree structure Panel - Placed 
• For all models placed on the panel sheet in the 2D view  
• For all models placed and visible on the panel sheet in the 3D view 

Note: If the model placed on the panel sheet has already been set/defined as 
transparent or invisible, the context menu command can only be called up in the 2D view 
or in the tree structure Panel - Placed. 

  

To set the visibility of a model: 

• right-click on the desired model(s) and move the mouse cursor over the context menu 
command Transparency in 3D 

• the following modes are available for selection under Transparency in 3D: 

• Visible/ Transparent / Invisible 
 
Example: "Invisible" 
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... with Mounted Devices Only the selected model(s) with mounted devices are 
invisible in the corresponding mode. 
 
Example: "Invisible with Mounted Devices" 

 

 
... except Selected Devices All models, except the selected model(s) are 
invisible in the corresponding mode. 

Example: "Invisible except Selected Devices" 
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... except Selected and Mounted Devices All models, except the selected model 
with mounted devices are invisible in the corresponding mode. 

Example: "Invisible except Selected and Mounted Devices"  

 

  

In the tree structure Panel - Placed the icon changes according to which state is selected: 

 

State Model 
Symbol 

Cable Duct 
Symbol 

Mount 
Symbol 

Connector 
Symbol 

Terminal 
Symbol 

Visible 

     

Transparent 

Invisible 

. 
 

  

To select all models and mounted devices in the entire project, proceed as follows: 

• right-click on the project name in the Panel - Placed tree, 
• select the command Visible / Transparent / Invisible from the displayed context 

menu. 

  

References: Designer-23224 
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References 

• New Drop-Down Menu 'Format:' in the Settings for Defining How the Text Type 
'Sheet Reference' Can Be Displayed 

New Drop-Down Menu 'Format:' in the Settings for Defining How the Text Type 
'Sheet Reference' Can Be Displayed  

In E3.series there are now several possibilities for displaying the text type 'Sheet reference': 

• Row/Column 
• Column/Row 
• Row 
• Column 

To do so, there is the new drop-down menu Format in the Settings under General - Display 
in the section Sheet Reference. 

Note: The already existing check box Show sheet layout has also been integrated in the 
section Sheet Reference.  
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Display 
 

Format: For the text type 'Sheet reference' the sheet coordinates of the reference 
target are displayed as follows: 

• Row/Column  
• Column/Row  
• Row  
• Column  

  

Note: When changing the format, the display of sheet references is 
automatically updated. The display of the signal format <.GRID> is 
updated automatically provided that an automatic recalculation is active. 

  

This check box is project-specific in a multi-user project. 

For the COM methods prj.GetSettingValue and prj.SetSettingValue the 
following setting_name can be used: SHEETREF_FORMAT. 

• job.SetSettingValue ( SHEETREF_FORMAT, value ) 
• value = job.GetSettingValue ( SHEETREF_FORMAT ) 

o value Permitted values: 

 0: Row/Column 
 1: Column/Row  
 2: Row 
 3: Column 
 If an invalid value is defined, Row/Column is used. 

. 
 

  

Reference(s): Designer-09802 
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Text 

• Two New Text Types in E3 for Referencing between Symbols in Circuit Diagrams 
and Components on Panel Sheets 

• Display of Multiline Texts Can Now Be Defined in the Symbol Properties for 
Symbols of the Type 'Attribute Text Template' 

• Lines Can Now Be Added to Text Boxes 
• Parameter Values Can Now Be Defined using Placeholders for Translated Text 

Nodes from the Translation Table 
• Ten New Sheet Text Types in the Database  

Two New Text Types in E3 for Referencing between Symbols in Circuit Diagrams and 
Components on Panel Sheets 

The following two new text types are now available in E3: 

• Reference to Schematic (#1141 )  
• Reference to Panel (#1142 ) 

Both text types can be defined on symbols and components in database editor mode. 

Reference to Schematic 

This text type displays all positions of the master symbols which are defined on the device. If 
no master is defined on the device, the first symbol will be referenced. If no first symbol is 
placed, the referencing remains empty. If there are several reference destinations due to 
several defined master symbols, the reference symbols will not be displayed according to their 
position. The definition on the component will be used as sequence instead. 

  

Reference to Panel 

This text type displays all positions on which the model is visible. 

  

Reference(s): Designer-14358 

Display of Multiline Texts Can Now Be Defined in the Symbol Properties for Symbols 
of the Type 'Attribute Text Template' 

It's now possible to define how several values shall be displayed for symbols of the type 
Attribute text template. 

Note: Several values may exist due to option combinations (i.e. different instances of a wire 
within a project). 

To do so, there is the new check box Show all values in multiline texts in Project mode and 
Database Editor mode within the Symbol Properties in the tab Symbol: 

How the dialog is displayed within project 
mode: 

How the dialog is displayed within 
database editor mode: 
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Symbol Properties  
 

Show all values 
in multiline 
texts 

Several values are displayed on attribute text template symbols as follows 
when several instances of conductors/wires exist:  

• If the check box is not checked, only one line with the entry 
<multiple values> is displayed: 

 

•  If the check box is checked, the individual values are displayed in 
separate lines: 
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. 
 

  

Reference(s): Designer-25426 

Lines Can Now Be Added to Text Boxes  

For texts a line can now be added to the text box. The line is placed at the 'top', 'center' or 
'bottom' of the text box. To do so, there are three new radio buttons in the section Line in the 
tab Text of the Text Properties:  
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Text Properties - Text 
 

Ballooning 

Line 

Top text box When activating this option, a line is added at the top of the text box. 

Center text box  When activating this option, a line is added in the middle of the text box. 
  

Bottom text 
box 

When activating this option, a line is added at the bottom of the text box.  
  

. 
 

  

Reference(s):  Designer-26481 

Parameter Values Can Now Be Defined using Placeholders for Translated Text Nodes 
from the Translation Table  

A parameter value can now be defined for translated text nodes using a placeholder. This 
placeholder is created in the Translation Table in the Database Editor. In later projects the real 
parameter value is defined in the text.  

To create the placeholder in the Database Editor: 

• Start the Database Editor and select the command Format -> Translation Table... in 
the main menu 

• Create the placeholder using the character combination %s 
Note: If %s is to be used as text and not as a placeholder, then use the following: \%s 

• Enter the desired text in the required language along with its placeholder (see example 
with text node &#1020;): 

 
• Save the modifications in the database. 

  

To define the parameter value in the project: 

•  Execute the command Update configuration in project   
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• Insert the translated text node (in the example &#1020;) in the project: 

 
• The parameter value is defined using a dollar sign $:  

Note: If the dollar sign $ is to be used as text and not as a parameter value, then do so 
as follows: \$ 

 
• The text is now displayed with the defined parameter values:  

 

Note: 

• If no parameter value is defined, an empty space appears in the text.  
• For multiline texts the parameter value must appear at the end of the text.  

  

Reference(s):  Designer-11332 

Ten New Sheet Text Types in the Database  

In E3.series there are ten new sheet text types under Edit Text Types in Database Editor 
Mode. With these text types one can define their own text nodes in the project to have a better 
overview when working with substructures.  

The following new text types are available: 
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Type Name Max. 
Length 

Owner Description 

1150  Number of sheets in 
folder 

255 Sheet 
Shows the number of sheets in 
the folder. 

1151 Previous sheet in the 
folder 

64 Sheet 
Shows the previous sheet in the 
folder. 

1152 Following sheet in the 
folder 

64 Sheet Shows the next sheet in the 
folder. 

1153 First sheet in folder 64 Sheet Shows the first sheet in the 
folder. 

1154 Last sheet in folder 64 Sheet Shows the last sheet in the folder. 

1155 Has following sheet in 
folder? 

255 Sheet Plus sign (+):  
A following sheet is available in 
the folder. 

Minus sign (-): 
There is no following sheet in the 
folder. 

1156 Previous sheet in 
project 

64 Sheet 
Shows the previous sheet in the 
project. 

1157 First sheet in project 64 Sheet 
Shows the first sheet in the 
project. 

1158 Last sheet in project 64 Sheet 
Shows the last sheet in the 
project. 

1159 Has following sheet in 
project? 

255 Sheet 
Plus sign (+):  
A following sheet is available in 
the project. 

Minus sign (-): 
There is no following sheet in the 
project.  

The following text types are already there: 

Type Name Max. 
Length 

Owner Description 
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31 Number of sheets in 
project  

255 Sheet 
Shows the number of sheets in the 
project. 

1020 Following sheet in 
project 

64 Sheet Shows the following sheet in the 
project. 

  

Reference(s):  Designer-08042 
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User Interface 

• 'Full Screen Mode' for Workspace in E3.series 

'Full Screen Mode' for Workspace in E3.series 

In E3.series there is now a full screen mode. In this full screen mode the workspace area of 
one or more sheets is projected on the complete screen. This is advantageous for drawings 
with numerous components. 

Note: This functionality is only available for a project that is already opened. 

  

Starting the Full Screen Mode 

To start the full screen mode, 

• select the command View -> Full screen in the main menu, or 
• press the F11 key. 

 

  

In the Customize dialog (called up using Tools -> Customize - Application Look) there is 
the new check box Display main menu in full screen mode:  
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If checked, the main menu toolbar is displayed in full screen mode. Using the main menu 
toolbar the project, database and output windows as well as tables can be displayed in full 
screen mode. 

Note: Changes to workspace configurations are not saved when closing the full screen mode. 
The saving and loading of workspace configurations is deactivated in full screen mode. 

  

Closing the Full Screen Mode 

To close the full screen mode, 

• select the command View -> Full Screen in the main menu, or 
• select the command Close Full Screen in the Full Screen dialog, or 
• press the F11 key. 

 

  

Reference(s): Designer-15129 
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Variants / Options 

• Variants/Options Tree Can Now Be Structured using Folders 
• All Elements in Variants/Options Tree Can Now Be Sorted in Ascending or 

Descending Order 

Variants/Options Tree Can Now Be Structured using Folders 

From now on the Variants/Options Tree can be displayed as a structured folder. This folder 
represents the values of the sorting attributes, which are created automatically after being 
defined. If one of the following objects...  

o variants 
o options 
o packages 
o configurations  
o harness families 

has this sorting attribute, it is automatically sorted in the corresponding folder.  

  

So that the attributes can be displayed in the Variants/Options Tree, the new owner 
'Variants/Options' must be defined on the respective attribute in Database Editor Mode 
under Format -> Attribute Names...: 

 

Note: For existing projects the configuration must be updated afterward in the project.  

  

Now the required attributes must be defined for the objects (variants, options, packages, 
configurations and harness families). 

• Right-click on the desired object in the Variants/Options Tree and select the context 
menu command Properties..., 
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• next select the new Attribute Values tab in the 'Properties' dialog: 

 

  

The next step is to define which attributes shall be used as sorting criteria in the 
Variants/Options Tree.  

• Right-click in the Variants/Options Tree in the Project Window and select the context 
menu command Tree Control Properties..., 

• select the new Sorting tab in the 'Tree Control Properties' dialog 

Using Keys 1-5 a sorting attribute can be defined in the respective drop-down list for the 
Variants/Options Tree: 
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Variants/Options Tree without Structuring: 
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Variants/Options Tree with Structuring: 

 

Note: 

• When exporting/importing the structure, the attributes on the objects are transferred as 
well. 

• When moving objects to another folder, they receive the attributes necessary for the 
structuring. 

• When moving objects in a folder, they are sorted after the last object in the folder. 
• Folders can be renamed. In doing so, the attribute values of all underlying objects are 

correspondingly adapted. 
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• The folder has a context menu command for creating objects. These receive the required 
attributes for the structuring and are sorted after the last object in the folder. 

  

Note: If the structure is locked, 

o the folders are displayed as grayed-out in the tree 
o the objects can no longer be moved to another folder 
o the folders can no longer be renamed 
o the attribute values in the Properties can no longer be changed on the objects. 

  

New COM Commands in OptionInterface for Editing Attributes 

The following new COM commands are now also available in the OptionInterface: 

• AddAttributeValue ( name, value ) 
• DeleteAttribute ( name ) 
• GetAttributeValue ( name ) 
• SetAttributeValue ( name, value ) 
• HasAttribute ( name ) 
• GetAttributeIds ( ids, [attnam] ) 

  

Reference(s): Designer-24877 

All Elements in Variants/Options Tree Can Now Be Sorted in Ascending or 
Descending Order 

From now on all elements (variants/options, packages/configurations, harness families/harness 
derivatives) in the Variants/Options Tree can be sorted in ascending or descending order. To 
do so, there are the new context menu commands Sort ascending / Sort descending.  

Note: Depending on which level the context menu command is executed, all underlying 
(subjacent) elements are sorted. 

Enhancement to OptionInterface for Sorting Variants/Options in Project Tree 

The following new COM command is available in the OptionInterface: 

• ret = opt.Sort ( ascending ) 

o ascending The following values are possible: 

 0 Sort descending (default) 
 1 Sort ascending 

o ret The return value is 1 if successful, otherwise 0.  

Reference(s): Designer-14957 
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Views 

• Dialogs 'New View' and 'Place on Formboard' Have Been Enhanced 
• Control whether Active Connector Pin Terminal Symbol Shall Be Displayed for 

Views in the Device Properties 
• Keep pinview symbols at project update 

Dialogs 'New View' and 'Place on Formboard' Have Been Enhanced 

When placing a new device view, the functionality in the following dialogs has been changed: 

• New View 
• Place on Formboard 

In the New View dialog the device view is placed on a schematic sheet: 

 

In the Place on Formboard dialog the device view is placed on a formboard sheet:  
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If the check box Use active connector pin terminal is checked, the symbol of the connector 
pin terminal is now used for the respective pin. 

Note: 

• If the same connector pin terminal is used on all pins, this connector pin terminal symbol 
appears in the Preview Window.  

• If different connector pin terminals are used on the pins, a corresponding message 
appears in the Preview Window.  

• In the tree structure the user-defined view number is now also displayed (if available). 

Furthermore, the previous selection field complete connector has been renamed complete 
device (So far, this functionality was only valid for connectors). If this selection field is active, 
the device view is placed as the complete device. 

  

Reference(s): Designer-25703 

Control whether Active Connector Pin Terminal Symbol Shall Be Displayed for Views 
in the Device Properties 

For device views and pin views it's now possible to control whether the active connector pin 
terminal symbol shall be placed instead of the previous view symbol (in case a symbol is 
defined). 
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To do so, there is a new check box Use pin terminal symbols in the Device tab of the 
Device Properties. 

 

If the check box Use pin terminal symbols: is checked, the presently set connector pin 
terminal symbol is used.  

Note: 

• This is only valid though in the single pin display. If a single pin is split from a complete 
connector, the active connector pin terminal symbol is used. 

• Additionally, please note that the view of the symbol (top view, side view,...) is retained. 
If the previous view symbol was a formboard symbol, then a formboard symbol (if 
available) would be used for the active connector pin terminal.  

• If the connector pin terminal symbol cannot be determined/swapped, a corresponding 
message appears (with the item designation and 'Jump to' functionality) in the message 
window.  
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• When placing a device view, the check box Use pin terminal symbols: is automatically 
set to active as soon as the options Place as: single pins and Use active connector 
pin terminal are activated in the New View dialog. 

•  When updating components in the project, the setting of the check box Use pin 
terminal symbols: is considered. 

If the check box Use pin terminal symbols: is deactivated, the symbol momentarily placed is 
used and an automatic update is no longer possible. 

  

Multi-User Limitations  

The following is valid in the multi-user environment: 

If a variant/option (for example with pins, placed wires/conductors or assemblies) is involved 
with a device/pin view, the connector pin terminal symbol is not swapped and a warning 
appears in the message window instead. 

Nevertheless, it is possible to get around this restriction in order to display the correct 
connector pin terminal symbol, e.g. for a printout. 

 To do so, there is the new icon  Update pin terminal symbols in the Placement toolbar.  

Note: This symbol list is only active in multi-user projects. 

New COM Commands in DeviceInterface for the Setting 'Use pin terminal symbols' 

In DeviceInterface there are the following new COM commands: 

• ret = dev.IsPinTerminalSymbolsUsed 

o ret The return value is 1 if the connector pin terminal symbols are used for the set 
device, otherwise 0. 

• ret = dev.SetPinTerminalSymbolsUsed ( use ) 

o use 1 The connector pin terminal symbols are used for the set device. 
o use 0 The normal view symbols are used for the set device. 
o ret The return value is 0 if successful, otherwise -1. 

  

Reference(s): Designer-22521 

Keep pinview symbols at project update 

The setting Update in Project offers the possibility to control whether already placed pinview 
symbols shall be kept or not. 

For using this function click the check box Keep pinview symbols of devices within the 
Pins’ area in the settings category General – Update in Project: 
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Update in project  
 

Keep pinview 
symbols of 
devices 

With active option all pinview symbols for devices are kept at project 
update. 

With inactive option no pinview symbols are kept for devices at project 
update but the symbol defined as attribute within the database is used. 

Note: When no symbol definition is existing over an attribute on the pins, 
the set symbol (under Settings ->Placement ->Symbols->Symbol 
Views-> For device pins ) will be used. 
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The following setting_name can be used for the COM-methods 
prj.GetSettingValue and prj.SetSettingValue: 
KEEP_PINVIEW_SYMBOLS_OF_DEVICE 

This check box is user-specific for Multiuser-projects. 

. 
 

Reference(s): Designer-25350 
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